Skip to main content

Changelog

0.49.0#

πŸš€ Features#

πŸ› Bug Fixes#

  • [#3673] Downgrade camelcase [#3674]
  • [#3361] Fixed z-Index issue on customize page chatplugin [#3663]
  • [#3664] Fixed connect button and fixed notification color [#3665]
  • [#3631] Control center reorganize routing for connectors [#3660]
  • [#3560] Control center remove sources info component [#3624]
  • [#3634] Support whatsApp source in the render library [#3637]
  • [#3671] Restructure backend directories [#3672]
  • [#3662] Update DynamoDB with configuration values and remove enum ComponentName in model lib [#3666]

πŸ“š Documentation#

🧰 Maintenance#

  • Bump jest-environment-jsdom from 28.1.3 to 29.0.1 [#3656]
  • Bump typescript from 4.7.4 to 4.8.2 [#3649]
  • Bump core-js from 3.24.1 to 3.25.0 [#3657]
  • Bump react-i18next from 11.18.4 to 11.18.5 [#3658]
  • Bump webpack-dev-server from 4.10.0 to 4.10.1 [#3659]
  • Bump babel-jest from 28.1.3 to 29.0.1 [#3650]
  • Bump camelcase-keys from 7.0.2 to 8.0.2 [#3651]
  • Bump @types/node from 18.7.11 to 18.7.13 [#3652]
  • Bump eslint-plugin-react from 7.30.1 to 7.31.1 [#3653]
  • Bump @types/node from 18.7.9 to 18.7.11 [#3632]
  • Bump dotenv-webpack from 8.0.0 to 8.0.1 [#3617]
  • Bump terser-webpack-plugin from 5.3.4 to 5.3.5 [#3619]
  • Bump preact from 10.10.2 to 10.10.6 [#3620]
  • Bump @babel/core from 7.18.10 to 7.18.13 [#3629]
  • Bump @reduxjs/toolkit from 1.8.4 to 1.8.5 [#3630]
  • Bump cypress from 10.4.0 to 10.6.0 [#3627]
  • Bump webpack-bundle-analyzer from 4.5.0 to 4.6.1 [#3628]
  • Bump i18next from 21.9.0 to 21.9.1 [#3626]
  • Bump sass from 1.54.4 to 1.54.5 [#3621]
  • Bump @types/node from 18.7.4 to 18.7.9 [#3618]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.48.0#

Changes#

πŸš€ Features#

πŸ› Bug Fixes#

  • [#3600] Display all components in catalog [#3602]
  • [#3529] Align title fontsize customize and install
  • [#3571] Update dialogflow configuration form [#3576]
  • [#3563] Update components.get handling [#3564]
  • [#3608] Fix chatplugin preview url [#3612]
  • [#3605] Fix connectors connected channels [#3610]
  • [#3600] Display all components in catalog [#3602]
  • [#3591] Enhancement enable/disable [#3601]
  • [#3603] Fix integration-source-api helm code [#3604]
  • [#3589] Retrieve installed components from cm [#3592]
  • [#3529] Align title fontsize customize and install [#3590]
  • [#3571] Update dialogflow configuration form [#3576]
  • [#3508] Fix empty state connectors [#3588]
  • [#3572] Use only Kafka when provisioning topics
  • [#3504] Set minimum Kafka replicas to 1 [#3506]
  • [#3511] Update helm repo before install or upgrade [#3512]
  • [#3530] Airy controller component name mapping [#3562]
  • [#3540] Simplify the spanish flag to reduce bundle size [#3559]
  • [#3541] Rename module for airy-core [#3547]
  • [#3465] Status view enable button error when component is not configured [#3481]

πŸ“š Documentation#

  • [#3539] Documentation update for minikube installation [#3566]
  • [#3373] Document how we work with rules_go, gazelle, and update-deps [#3521]
  • [#3558] Docs for Contributing and Defining Components [#3574]

🧰 Maintenance#

  • Bump @reduxjs/toolkit from 1.8.3 to 1.8.4 [#3593]
  • Bump @emoji-mart/data from 1.0.3 to 1.0.5 [#3594]
  • Bump @testing-library/dom from 8.16.1 to 8.17.1 [#3595]
  • Bump @types/jest from 28.1.6 to 28.1.7 [#3598]
  • Bump react-i18next from 11.18.3 to 11.18.4 [#3596]
  • Bump @types/node from 18.7.3 to 18.7.4 [#3597]
  • Bump webpack-dev-server from 4.9.3 to 4.10.0 [#3585]
  • Bump ts-jest from 28.0.7 to 28.0.8 [#3583]
  • Bump preact from 10.10.1 to 10.10.2 [#3584]
  • Bump sass from 1.54.3 to 1.54.4 [#3586]
  • Bump emoji-mart from 5.2.0 to 5.2.1 [#3587]
  • Bump @emoji-mart/react from 1.0.0 to 1.0.1 [#3578]
  • Bump terser-webpack-plugin from 5.3.3 to 5.3.4 [#3579]
  • Bump @types/node from 18.6.4 to 18.7.3 [#3581]
  • Bump i18next from 21.8.16 to 21.9.0 [#3580]
  • Bump @testing-library/user-event from 14.4.2 to 14.4.3 [#3582]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.47.4#

Hotfix#

  • [#3575] Fix Kafka topics provisioning

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.47.3#

Hotfix#

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.47.2#

Hotfix#

  • [#3553] Fix using a custom Kafka when installing Airy via Helm

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.47.1#

Hotfix#

  • [#3510] Fix Kafka replication factor setting

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.47.0#

Changes#

πŸš€ Features#

πŸ› Bug Fixes#

πŸ“š Documentation#

🧰 Maintenance#

  • Bump terser from 4.8.0 to 4.8.1 in /docs [#3462]
  • Bump camelcase-keys from 7.0.2 to 8.0.1 [#3443]
  • Bump @testing-library/user-event from 14.2.1 to 14.2.6 [#3452]
  • Bump ts-jest from 28.0.5 to 28.0.7 [#3451]
  • Bump react-i18next from 11.18.0 to 11.18.1 [#3447]
  • Bump jest-environment-jsdom from 28.1.2 to 28.1.3 [#3446]
  • Bump sass-loader from 13.0.0 to 13.0.2 [#3429]
  • Bump @bazel/typescript from 5.5.0 to 5.5.2 [#3408]
  • Bump @types/jest from 28.1.4 to 28.1.5 [#3431]
  • Bump dotenv-webpack from 7.1.1 to 8.0.0 [#3428]
  • Bump react-test-renderer from 18.1.0 to 18.2.0 [#3430]
  • Bump react-i18next from 11.17.4 to 11.18.0 [#3427]
  • Bump react-dom and @types/react-dom [#3425]
  • Bump eslint-plugin-react from 7.30.0 to 7.30.1 [#3417]
  • Bump ts-node from 10.8.1 to 10.8.2 [#3422]
  • Bump sass from 1.52.1 to 1.53.0 [#3419]
  • Bump @testing-library/dom from 8.14.0 to 8.16.0 [#3418]
  • Bump cypress from 10.1.0 to 10.3.0 [#3415]
  • Bump i18next from 21.8.10 to 21.8.13 [#3416]
  • Bump @types/node from 18.0.1 to 18.0.3 [#3400]
  • Bump @babel/preset-react from 7.17.12 to 7.18.6 [#3412]
  • Bump @reduxjs/toolkit from 1.8.2 to 1.8.3 [#3414]
  • Bump @babel/preset-env from 7.18.2 to 7.18.6 [#3401]
  • Bump core-js from 3.23.2 to 3.23.4 [#3409]
  • [#3354] Fix release script [#3405]
  • Bump webpack-cli from 4.9.2 to 4.10.0 [#3387]
  • Bump @babel/preset-typescript from 7.17.12 to 7.18.6 [#3385]
  • Bump @babel/plugin-proposal-object-rest-spread from 7.18.0 to 7.18.6 [#3390]
  • Bump preact from 10.8.2 to 10.9.0 [#3386]
  • Bump react and @types/react [#3381]
  • Bump jest-environment-jsdom from 28.1.1 to 28.1.2 [#3375]
  • Bump react-refresh from 0.13.0 to 0.14.0 [#3382]
  • Bump dotenv-webpack from 7.1.0 to 7.1.1 [#3374]
  • Bump @testing-library/dom from 8.13.0 to 8.14.0 [#3379]
  • Bump @types/node from 18.0.0 to 18.0.1 [#3380]
  • Bump babel-jest from 28.1.1 to 28.1.2 [#3372]
  • Bump @babel/plugin-transform-spread from 7.17.12 to 7.18.6 [#3370]
  • Bump webpack-dev-server from 4.9.2 to 4.9.3 [#3367]
  • Bump react-i18next from 11.17.2 to 11.17.4 [#3371]
  • Bump jest and @types/jest [#3364]
  • Bump typescript from 4.7.3 to 4.7.4 [#3365]
  • Bump @babel/core from 7.18.2 to 7.18.6 [#3366]
  • Bump reselect from 4.1.5 to 4.1.6 [#3326]
  • Bump @testing-library/user-event from 14.2.0 to 14.2.1 [#3331]
  • Bump preact from 10.7.3 to 10.8.2 [#3344]
  • Bump camelcase-keys from 7.0.2 to 8.0.1 [#3345]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.46.0#

Changes#

πŸš€ Features#

  • [#3332] Authenticate AWS using profile [#3335]
  • [#3336] UI Improvements for Control Center and DarkMode [#3337]
  • [#3095] Enable disable toggle control center [#3302]
  • [#3169] Redesign chatplugin customization [#3299]
  • [#3178] Enable disable components from control center [#3245]

πŸ› Bug Fixes#

πŸ“š Documentation#

🧰 Maintenance#

  • Bump core-js from 3.22.7 to 3.23.2 [#3325]
  • Bump @types/jest from 28.1.1 to 28.1.2 [#3327]
  • Bump i18next from 21.8.9 to 21.8.10 [#3310]
  • Bump react-i18next from 11.17.0 to 11.17.2 [#3312]
  • Bump @types/node from 17.0.42 to 18.0.0 [#3311]
  • Bump prettier from 2.6.2 to 2.7.1 [#3313]
  • Bump @types/react from 18.0.9 to 18.0.12 [#3278]
  • Bump ts-jest from 28.0.3 to 28.0.5 [#3287]
  • Bump i18next from 21.8.5 to 21.8.9 [#3288]
  • Bump ts-node from 10.8.0 to 10.8.1 [#3281]
  • Bump @types/node from 17.0.36 to 17.0.42 [#3282]
  • Bump preact from 10.7.2 to 10.7.3 [#3276]
  • Bump @bazel/typescript from 5.4.0 to 5.5.0 [#3183]
  • Bump webpack from 5.72.1 to 5.73.0 [#3277]
  • Bump jest and @types/jest [#3272]
  • Bump jest-environment-jsdom from 28.1.0 to 28.1.1 [#3271]
  • Bump babel-jest from 28.1.0 to 28.1.1 [#3273]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.45.1#

Hotfix#

  • [#3267] Putting components.* endpoints behind auth

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.45.0#

Changes#

πŸš€ Features#

πŸ› Bug Fixes#

πŸ“š Documentation#

🧰 Maintenance#

  • Bump terser-webpack-plugin from 5.3.1 to 5.3.3 [#3254]
  • Chore/upgrade go to 1.18.2 [#3244]
  • Bump eventsource from 1.0.7 to 1.1.1 in /docs [#3239]
  • Bump copy-webpack-plugin from 10.2.4 to 11.0.0 [#3202]
  • Bump @types/node from 17.0.35 to 17.0.36 [#3223]
  • Bump i18next from 21.8.4 to 21.8.5 [#3224]
  • Bump sass-loader from 12.6.0 to 13.0.0 [#3220]
  • Bump @types/node from 17.0.26 to 17.0.35 [#3218]
  • Bump @babel/core from 7.18.0 to 7.18.2 [#3216]
  • Bump react-redux from 8.0.1 to 8.0.2 [#3217]
  • Bump babel-loader from 8.2.4 to 8.2.5 [#3205]
  • Bump @reduxjs/toolkit from 1.8.1 to 1.8.2 [#3204]
  • Bump core-js from 3.22.5 to 3.22.7 [#3200]
  • Bump react-markdown from 8.0.2 to 8.0.3 [#3201]
  • Bump typescript from 4.6.3 to 4.6.4 [#3197]
  • Bump @babel/core from 7.17.9 to 7.18.0 [#3195]
  • Bump @babel/preset-env from 7.16.11 to 7.18.0 [#3194]
  • Bump sass from 1.50.0 to 1.52.1 [#3196]
  • Bump webpack-dev-server from 4.8.1 to 4.9.0 [#3152]
  • Bump react-modal from 3.14.4 to 3.15.1 [#3119]
  • Bump @babel/preset-typescript from 7.16.7 to 7.17.12 [#3189]
  • Bump redux from 4.1.2 to 4.2.0 [#3188]
  • Bump webpack from 5.72.0 to 5.72.1 [#3173]
  • Bump preact from 10.7.1 to 10.7.2 [#3172]
  • Bump core-js from 3.22.0 to 3.22.5 [#3151]
  • Bump @types/react-redux from 7.1.23 to 7.1.24 [#3062]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.44.0#

Changes#

πŸš€ Features#

πŸ› Bug Fixes#

πŸ“š Documentation#

🧰 Maintenance#

  • Bump react-redux from 7.2.8 to 8.0.1 [#3060]
  • chore/add mockito inline to deps [#3137]
  • chore/update test libraries [#3135]
  • Bump cross-fetch from 3.0.6 to 3.1.5 in /docs [#3113]
  • Bump react-i18next from 11.16.6 to 11.16.7 [#3097]
  • House clean/move contacts dto to library [#3112]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.43.0#

πŸš€ Features#

πŸ› Bug Fixes#

πŸ“š Documentation#

🧰 Maintenance#

  • Bump Bazel to 5.1.1 [#3054]
  • Bump async from 2.6.3 to 2.6.4 in /docs [#3042]
  • Bump async from 2.6.3 to 2.6.4 [#3041]
  • Bump react-i18next from 11.16.5 to 11.16.6 [#3043]
  • Bump core-js from 3.21.1 to 3.22.0 [#3044]
  • Bump @types/node from 17.0.23 to 17.0.24 [#3036]
  • Bump cypress from 9.5.3 to 9.5.4 [#3038]
  • Bump i18next from 21.6.15 to 21.6.16 [#3037]
  • Bump webpack-dev-server from 4.7.4 to 4.8.1 [#3020]
  • Bump i18next from 21.6.14 to 21.6.15 [#3019]
  • Bump @bazel/typescript from 5.3.1 to 5.4.0 [#3013]
  • Bump react-i18next from 11.16.2 to 11.16.5 [#3009]
  • Bump @babel/core from 7.17.8 to 7.17.9 [#3010]
  • Bump webpack from 5.71.0 to 5.72.0 [#3011]
  • Bump sass from 1.49.11 to 1.50.0 [#3012]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.42.0#

Changes#

πŸš€ Features#

πŸ› Bug Fixes#

πŸ“š Documentation#

🧰 Maintenance#

  • Bump @reduxjs/toolkit from 1.8.0 to 1.8.1 [#2998]
  • Bump sass from 1.49.9 to 1.49.11 [#2999]
  • Bump prettier from 2.6.0 to 2.6.2 [#2992]
  • Bump typescript from 4.6.2 to 4.6.3 [#2963]
  • Bump react-redux from 7.2.6 to 7.2.8 [#2993]
  • Bump preact from 10.6.6 to 10.7.1 [#2995]
  • Bump react-router-dom from 6.2.2 to 6.3.0 [#2996]
  • Bump react-markdown from 8.0.1 to 8.0.2 [#2984]
  • Bump minimist from 1.2.5 to 1.2.6 in /docs [#2990]
  • Bump @bazel/typescript from 5.2.0 to 5.3.1 [#2986]
  • Bump webpack from 5.70.0 to 5.71.0 [#2985]
  • Bump react-i18next from 11.16.1 to 11.16.2 [#2962]
  • Bump @types/node from 17.0.22 to 17.0.23 [#2961]
  • Bump babel-loader from 8.2.3 to 8.2.4 [#2965]
  • Bump cypress from 9.5.2 to 9.5.3 [#2983]
  • Bump @types/react from 17.0.41 to 17.0.43 [#2964]
  • [#2932] Fix the Changelog creation [#2977]
  • Bump copy-webpack-plugin from 9.0.1 to 10.2.4 [#2857]
  • Bump minimist from 1.2.5 to 1.2.6 [#2956]
  • Bump @types/react-dom from 17.0.13 to 17.0.14 [#2953]
  • Bump @types/node from 17.0.21 to 17.0.22 [#2954]
  • Bump @babel/core from 7.17.5 to 7.17.8 [#2952]
  • Bump @types/react from 17.0.40 to 17.0.41 [#2951]
  • Bump jvm rules external [#2955]
  • Bump @bazel/typescript from 4.6.1 to 5.2.0 [#2950]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

Upgrade notes#

This version introduces a new topology in the api-communication component. After the upgrade, the component needs to be reset. For more information how do do this refer to the docs for resetting a Kafka streaming app.

0.41.0#

πŸš€ Features#

πŸ› Bug Fixes#

🧰 Enhancements#

πŸ“š Documentation#

🧰 Maintenance#

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

Upgrade notes#

This release introduces a change in the structure of the airy.yaml file. The host setting is no longer present in the ingress-controller section and is moved to the global section. For more information refer to the configuration page.

0.40.0#

πŸš€ Features#

  • [#2742] List objects in s3 bucket [#2785]
  • [#2722] Webhook subscription editable and resubscribable [#2847]
  • [#2809] Added custom fonts to Chatplugin [#2832]

πŸ› Bug Fixes#

πŸ“š Documentation#

🧰 Maintenance#

  • Bump core-js from 3.21.0 to 3.21.1 [#2867]
  • Bump @babel/core from 7.16.7 to 7.17.4 [#2866]
  • Bump webpack from 5.69.0 to 5.69.1 [#2865]
  • Bump url-parse from 1.5.3 to 1.5.7 in /docs [#2864]
  • Bump i18next from 21.6.4 to 21.6.11 [#2855]
  • Bump react-i18next from 11.15.3 to 11.15.4 [#2859]
  • Bump webpack from 5.67.0 to 5.69.0 [#2856]
  • Bump @types/resize-observer-browser from 0.1.6 to 0.1.7 [#2853]
  • Bump preact from 10.6.5 to 10.6.6 [#2852]
  • Bump core-js from 3.20.3 to 3.21.0 [#2854]
  • Bump @types/react-window-infinite-loader from 1.0.5 to 1.0.6 [#2850]
  • Bump linkify-react from 3.0.1 to 3.0.4 [#2851]
  • Bump @types/node from 17.0.16 to 17.0.18 [#2848]
  • Bump css-loader from 6.5.1 to 6.6.0 [#2849]
  • Bump webpack-dev-server from 4.7.3 to 4.7.4 [#2841]
  • Bump @types/react-redux from 7.1.20 to 7.1.22 [#2846]
  • Bump webpack-cli from 4.9.1 to 4.9.2 [#2845]
  • Bump @reduxjs/toolkit from 1.6.2 to 1.7.2 [#2843]
  • Bump @svgr/webpack from 6.2.0 to 6.2.1 [#2842]
  • Bump follow-redirects from 1.14.7 to 1.14.8 in /docs [#2839]
  • Bump follow-redirects from 1.14.7 to 1.14.8 [#2840]
  • Bump camelcase-keys from 7.0.1 to 7.0.2 [#2821]
  • Bump @types/node from 16.10.3 to 17.0.16 [#2822]
  • Bump terser-webpack-plugin from 5.3.0 to 5.3.1 [#2794]
  • Bump @types/lodash-es from 4.17.5 to 4.17.6 [#2823]
  • Bump @types/react-router-dom from 5.3.1 to 5.3.3 [#2796]
  • Bump sass-loader from 12.3.0 to 12.4.0 [#2811]
  • Bump @types/react from 17.0.37 to 17.0.39 [#2812]
  • Bump @babel/preset-env from 7.16.8 to 7.16.11 [#2778]
  • [#2421] svg naming fix [#2806]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.39.0#

Changes#

πŸš€ Features#

πŸ› Bug Fixes#

  • [#2781] Endless loop for channels.list [#2783]
  • [#2764] Bug null pointer exception on api contacts service [#2767]
  • [#2715] Fixed notification badge after reload [#2765]

πŸ“š Documentation#

  • [#2693] Docs for contacts service endpoins [#2752]

🧰 Maintenance#

  • Bump @babel/plugin-proposal-object-rest-spread from 7.15.6 to 7.16.7 [#2776]
  • Bump css-loader from 6.2.0 to 6.5.1 [#2777]
  • Bump react-router-dom from 5.3.0 to 6.2.1 [#2749]
  • Update Bazel Dev Server [#2771]
  • Bump terser-webpack-plugin from 5.2.5 to 5.3.0 [#2760]
  • Bump node-fetch from 2.6.6 to 2.6.7 [#2763]
  • Bump webpack from 5.66.0 to 5.67.0 [#2762]
  • Bump react-i18next from 11.14.2 to 11.15.3 [#2761]
  • Bump nanoid from 3.1.23 to 3.2.0 [#2759]
  • Bump nanoid from 3.1.20 to 3.2.0 in /docs [#2758]
  • Bump react-modal from 3.14.3 to 3.14.4 [#2751]
  • Bump webpack-dev-server from 3.11.2 to 4.7.3 [#2729]
  • Bump core-js from 3.18.3 to 3.20.3 [#2748]
  • Bump nth-check from 2.0.0 to 2.0.1 [#2750]
  • Bump @bazel/typescript from 4.3.0 to 4.6.1 [#2741]
  • Bump @svgr/webpack from 5.5.0 to 6.2.0 [#2717]
  • Bump @babel/preset-env from 7.15.8 to 7.16.8 [#2732]
  • Bump reselect from 4.1.1 to 4.1.5 [#2621]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.38.1#

πŸ› Bug Fixes#

  • [#2736] Hotfix for re-provisioning topics on upgrade [#2740]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.38.0#

Changes#

  • [#2697] Fix Chatplugin Cutting in Web Browser [#2709]
  • [#2701] Add tags to terraform resources [#2702]

πŸš€ Features#

  • [#2577] Notification Badge Chatplugin [#2704]
  • [#2699] Kafka Connect is not activatable with Helm [#2700]
  • [#2293] Fix contact creation [#2698]
  • [#2691] Beanstalk service needs a label [#2692]
  • [#1246] Add documentation on how to run images locally [#2638]
  • [#2682] AKHQ for multiple namespaced Kafkas [#2683]
  • [#2675] NPM package release rule needs username… [#2679]
  • Add contacts service [#2628]
  • [#2676] Prefill missing inputs instagram channel [#2677]

πŸ› Bug Fixes#

πŸ“š Documentation#

  • [#2651] Helm installation tabItem is swapped [#2703]
  • [#2678] Make clear distiction between inbound outbound webhook [#2690]

🧰 Maintenance#

  • Bump i18next from 21.3.1 to 21.6.4 [#2686]
  • Bump @babel/plugin-proposal-class-properties from 7.16.5 to 7.16.7 [#2688]
  • Bump react-markdown from 7.1.0 to 7.1.2 [#2685]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.37.0#

Changes#

  • [#2653] upgrade slf4j and underlying log4j libraries [#2654]

πŸš€ Features#

πŸ› Bug Fixes#

πŸ“š Documentation#

  • [#2550] Docs for multiple providers using helm [#2597]

🧰 Maintenance#

  • Bump @babel/plugin-proposal-class-properties from 7.14.5 to 7.16.5 [#2656]
  • Bump terser-webpack-plugin from 5.2.4 to 5.2.5 [#2655]
  • Bump prettier from 2.4.1 to 2.5.1 [#2635]
  • Bump algoliasearch-helper from 3.4.4 to 3.6.2 in /docs [#2614]
  • Bump @babel/preset-typescript from 7.15.0 to 7.16.0 [#2599]
  • Bump webpack from 5.59.1 to 5.64.4 [#2620]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.36.1#

Changes#

πŸ› Bug Fixes#

  • [#2434] Fix instagram ingestion race condition [#2625]

🧰 Maintenance#

  • Bump webpack from 5.59.1 to 5.64.4 [#2620]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.36.0#

πŸš€ Features#

  • [#2604] Added attachment toggle for chatplugin [#2609]

πŸ› Bug Fixes#

🧰 Maintenance#

  • Bump camelcase-keys from 7.0.0 to 7.0.1 [#2624]
  • Bump @babel/plugin-transform-spread from 7.15.8 to 7.16.0 [#2593]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.35.1#

πŸš€ Features#

  • [#2586] Terraform core module has wrong Helm link [#2587]
  • [#2119] Send/render attachments chatplugin [#2603]

πŸ› Bug Fixes#

πŸ“š Documentation#

🧰 Maintenance#

  • Bump @babel/core from 7.15.8 to 7.16.0 [#2595]
  • Bump redux from 4.1.1 to 4.1.2 [#2566]
  • Bump react-i18next from 11.12.0 to 11.14.2 [#2581]
  • Bump eslint-plugin-react from 7.26.1 to 7.27.0 [#2588]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.35.0#

πŸš€ Features#

  • [#2455] Custom message colors chatplugin [#2585]
  • [#2108] Render attachments via whatsapp [#2574]
  • [#2518] Add terraform code for core deployment [#2555]
  • [#2563] Allow for disabling emojis in the chatplugin [#2564]
  • [#2560] Dev_cli.sh fails to apply the config [#2561]
  • [#2537] Print airy core version with version command [#2537]
  • [#2503] Add capability for resource limits for components [#2541]

πŸ› Bug Fixes#

πŸ“š Documentation#

  • [#2511] Fix docs for helm upgrade [#2547]
  • [#2455] Documentation for custom message colors chatplugin [#2585]

🧰 Maintenance#

  • Bump @types/react-dom from 17.0.10 to 17.0.11 [#2572]
  • Bump style-loader from 3.3.0 to 3.3.1 [#2573]
  • Bump cypress from 8.6.0 to 8.7.0 [#2567]
  • Bump babel-loader from 8.2.2 to 8.2.3 [#2568]
  • Bump @types/react from 17.0.20 to 17.0.34 [#2553]
  • Bump sass from 1.43.2 to 1.43.4 [#2565]
  • Bump node-fetch from 2.6.2 to 3.0.0 [#2450]
  • Bump html-webpack-plugin from 5.3.2 to 5.5.0 [#2552]
  • Bump prettier from 2.3.2 to 2.4.1 [#2532]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.34.0#

Changes#

πŸš€ Features#

πŸ› Bug Fixes#

🧰 Maintenance#

  • Bump react-redux from 7.2.5 to 7.2.6 [#2539]
  • Bump reselect from 4.0.0 to 4.1.1 [#2533]
  • Bump sass-loader from 12.1.0 to 12.3.0 [#2534]
  • Bump @types/react-dom from 17.0.9 to 17.0.10 [#2526]
  • Bump react-markdown from 7.0.1 to 7.1.0 [#2527]
  • Bump webpack from 5.54.0 to 5.59.1 [#2517]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.33.0#

πŸš€ Features#

  • [#2294] Allow creating conversations with Twilio [#2500]
  • [#2476] render deleted message instagram [#2501]
  • [#2453] Store chatplugin customization state in the browser [#2475]
  • [#2323] Pass Google survey response as message [#2471]
  • [#2255] Modular deployment of Airy with helm [#2341]
  • [#2437] Add translations to chatplugin [#2465]
  • [#2424] track channel connected [#2447]

πŸ› Bug Fixes#

🧰 Maintenance#

  • Bump cypress from 8.5.0 to 8.6.0 [#2516]
  • Bump @types/react-redux from 7.1.19 to 7.1.20 [#2515]
  • Bump sass from 1.42.1 to 1.43.2 [#2496]
  • Bump @babel/preset-env from 7.15.6 to 7.15.8 [#2498]
  • Bump babel-loader from 8.0.6 to 8.2.2 [#2499]
  • Bump @reduxjs/toolkit from 1.6.1 to 1.6.2 [#2494]
  • Bump i18next from 21.3.0 to 21.3.1 [#2497]
  • Bump preact from 10.5.14 to 10.5.15 [#2493]
  • Bump @types/lodash-es from 4.17.4 to 4.17.5 [#2495]
  • Bump @bazel/typescript from 3.6.0 to 4.3.0 [#2459]
  • Bump webpack-bundle-analyzer from 4.4.2 to 4.5.0 [#2490]
  • Bump @types/react-router-dom from 5.1.8 to 5.3.1 [#2492]
  • Bump core-js from 3.18.1 to 3.18.3 [#2491]
  • [#2353] Change backend urls to hyphenation [#2472]
  • Bump typescript from 4.2.4 to 4.3.5 [#2486]
  • Bump i18next from 21.2.0 to 21.3.0 [#2487]
  • Bump @typescript-eslint/eslint-plugin from 4.32.0 to 4.33.0 [#2482]
  • Bump @types/react-redux from 7.1.18 to 7.1.19 [#2485]
  • Bump @babel/core from 7.15.5 to 7.15.8 [#2483]
  • Bump eslint-plugin-react from 7.26.0 to 7.26.1 [#2479]
  • Bump @types/node from 16.9.4 to 16.10.3 [#2480]
  • Bump linkifyjs from 2.1.9 to 3.0.1 [#2462]
  • Bump immer from 9.0.5 to 9.0.6 [#2466]
  • Bump @typescript-eslint/parser from 4.31.2 to 4.32.0 [#2458]
  • Bump style-loader from 3.2.1 to 3.3.0 [#2460]
  • Bump prismjs from 1.24.0 to 1.25.0 in /docs [#2428]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

Upgrade notes:#

This release has breaking changes in the structure of the airy.yaml file. When upgrading from an older version, do the following:

  • Remove the kubernetes: section, as it is no longer needed. The version is used from the version of the CLI and the - namespace is used from the workspace file cli.yaml
  • Rename the ingress: section to ingress-controller:

0.32.0#

Changes#

πŸš€ Features#

  • [#2443] Allow for compatability with mobile login flows [#2444]
  • [#2423] track core installation [#2430]

πŸ› Bug Fixes#

🧰 Maintenance#

  • Bump webpack from 5.51.1 to 5.54.0 [#2440]
  • Bump core-js from 3.17.2 to 3.18.1 [#2438]
  • Bump @typescript-eslint/parser from 4.31.0 to 4.31.2 [#2439]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.31.1#

πŸš€ Features#

πŸ› Bug Fixes#

🧰 Enhancements#

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.31.0#

πŸš€ Features#

  • [#628] Make library compatible with node.js [#2426]
  • [#2405] Icons for Rendering/Sending File Attachments [#2420]
  • [#2406] Instagram Source: Render Messages with Media & Share in Inbox UI [#2419]
  • [#2109] Render send file attachments via facebook messenger [#2404]
  • [#2257] Add analytics demo [#2325]

πŸ› Bug Fixes#

πŸ“š Documentation#

🧰 Maintenance#

  • Bump cypress from 8.3.1 to 8.4.1 [#2418]
  • Bump @babel/preset-env from 7.15.4 to 7.15.6 [#2417]
  • Bump axios from 0.21.1 to 0.21.4 in /docs [#2410]
  • Bump @types/node from 16.7.13 to 16.9.4 [#2415]
  • Bump terser-webpack-plugin from 5.2.3 to 5.2.4 [#2398]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

Upgrade notes#

In the airy.yaml file, host is moved from the kubernetes section, into the ingress section.

0.30.0#

πŸš€ Features#

  • [#2274] Introduce the source API [#2327]
  • [#2328] Display any source in the inbox [#2368]
  • [#2227] Instagram source show story reply in inbox UI [#2367]
  • [#2229] Instagram source render story mention in inbox UI [#2363]

πŸ› Bug Fixes#

  • [#2370] Fix inbox counter bug when paginating [#2371]
  • [#2337] Fix webhook publisher crash for deleted messages [#2340]
  • [#2275] Fixing typos in webhook docs [#2338]

πŸ“š Documentation#

🧰 Maintenance#

  • Bump sass from 1.38.2 to 1.39.0 [#2377]
  • Bump react-router-dom from 5.2.1 to 5.3.0 [#2373]
  • Bump core-js from 3.16.4 to 3.17.2 [#2375]
  • Bump @babel/preset-env from 7.15.0 to 7.15.4 [#2372]
  • Bump immer from 9.0.3 to 9.0.6 [#2369]
  • Bump terser-webpack-plugin from 5.1.4 to 5.2.0 [#2364]
  • Bump @typescript-eslint/eslint-plugin from 4.29.2 to 4.30.0 [#2356]
  • Bump react-markdown from 7.0.0 to 7.0.1 [#2365]
  • Bump @typescript-eslint/parser from 4.29.3 to 4.30.0 [#2361]
  • Bump @types/node from 16.7.1 to 16.7.10 [#2362]
  • Bump tar from 6.1.4 to 6.1.11 in /docs [#2359]
  • Bump @types/react-window-infinite-loader from 1.0.4 to 1.0.5 [#2348]
  • Bump core-js from 3.16.2 to 3.16.4 [#2357]
  • Bump @typescript-eslint/parser from 4.29.2 to 4.29.3 [#2350]
  • Bump eslint-plugin-react from 7.24.0 to 7.25.1 [#2343]
  • Bump cypress from 8.3.0 to 8.3.1 [#2344]
  • Bump @stomp/stompjs from 6.1.0 to 6.1.1 [#2347]
  • Bump react-router-dom from 5.2.0 to 5.2.1 [#2346]
  • Bump sass from 1.38.0 to 1.38.2 [#2342]
  • Bump @typescript-eslint/eslint-plugin from 4.29.1 to 4.29.2 [#2296]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

0.29.0#

Changes#

  • [#2304] Fixed broken link from Messages Send Section to Sources. [#2307]
  • [#2308] Chatplugin Customize Section Not Working [#2309]

πŸš€ Features#

πŸ› Bug Fixes#

  • [#2282] Hotfix for webhook registration health check [#2284]

🧰 Maintenance#

  • Bump react-markdown from 6.0.3 to 7.0.0 [#2317]
  • Bump @types/react from 17.0.18 to 17.0.19 [#2320]
  • Bump webpack from 5.50.0 to 5.51.1 [#2316]
  • Bump @types/node from 16.6.1 to 16.7.1 [#2318]
  • Bump cypress from 8.1.0 to 8.3.0 [#2311]
  • Bump core-js from 3.16.1 to 3.16.2 [#2312]
  • Bump @types/react from 17.0.17 to 17.0.18 [#2313]
  • Bump react-markdown from 6.0.3 to 7.0.0 [#2297]
  • Bump @babel/core from 7.14.8 to 7.15.0 [#2303]
  • Bump sass from 1.37.5 to 1.38.0 [#2306]
  • Bump webpack from 5.49.0 to 5.50.0 [#2302]
  • Bump @typescript-eslint/parser from 4.29.1 to 4.29.2 [#2295]
  • Bump core-js from 3.16.0 to 3.16.1 [#2298]
  • Bump @types/node from 16.4.13 to 16.6.1 [#2287]
  • Bump @babel/preset-typescript from 7.14.5 to 7.15.0 [#2288]
  • Bump webpack-cli from 4.7.2 to 4.8.0 [#2290]
  • Bump @typescript-eslint/parser from 4.29.0 to 4.29.1 [#2291]
  • Bump url-parse from 1.5.1 to 1.5.3 [#2268]

Airy CLI#

You can download the Airy CLI for your operating system from the following links:

MacOS Linux Windows

Last updated on